PHP, which is an abbreviation for PHP: Hypertext Preprocessor, is one of the most commonly used server-side programming languages that are available out there. Any site or application created using PHP will run on a given server provided that a PHP module is installed, which renders the language truly universal and it isn’t very surprising that there are actually several million servers that support it and hundreds of millions of PHP-driven websites hosted on them. PHP is preferred over HTML because it enables you to build a responsive website with many options. A PHP-based social networking site, for example, will show different content to each visitor despite the fact that the URL will remain unchanged. By contrast, HTML sites are static and the page content itself can be updated only manually. Just like any other piece of software, PHP has different versions and the one that was used while building a specific website must be installed on the web server in order for the site to work properly.

PHP 4 and PHP 5 Support in Hosting

Our hosting servers support several versions of PHP, which implies that your websites will work without any problems no matter if your scripts are outdated. We know that an old website does not automatically imply a vulnerable one as you may have done lots of source code mods. That’s why we support PHP 4, 5.2, 5.3, 5.4 and 5.5 and you can pick which one will be active for your hosting account. The version can be changed with just one single mouse click in your Hepsia Control Panel and the new settings will take effect momentarily. If you wish to run both newer and older scripts, there’s even a possibility to use a different version of PHP for each domain name of yours simultaneously.

PHP 4 and PHP 5 Support in Semi-dedicated Hosting

Our Linux semi-dedicated hosting packages support multiple versions of PHP, so you will be able to use all the applications that you’ve created throughout the years. The Hepsia hosting Control Panel, which comes with each account, will enable you to activate the version that you need with one click. You can choose between PHP 5.5, 5.4, 5.3, 5.2 and 4. If you wish to host multiple websites in the exact same account and they have special requirements as regards the web hosting platform, you will be able to choose a different PHP version for each one of them regardless of which version has been selected for the account itself. That’s accomplishable thanks to our in-house built cloud platform, which permits us to run multiple PHP versions all at once. In comparison, most hosting companies usually offer one, rarely two versions.